Jump to content
Catutigernos

Servoyu RS-232 ile programlama sorunu

Recommended Posts

Merhaba,

RS232 Seri Bağlantı Portu X3 kullanmanız ve aşağıda yer bağlantıyı yapmanız halinde bağlantı kurabilmeniz gerekli. Bağlantı ve kablolamayı nasıl yaptığınız ve RS232 USB dönüştürücü olarak hangi ürünü tercih ettiğiniz hakkında da bilgi paylaşırsanız hatanın nereden ve nasıl kaynaklandığı hakkında daha açıklayıcı olabilir. 

image.png.bbacea6ab6781b8bc5afe506e9bfa7f4.png

İyi günler.

Link to comment
Share on other sites

Samet KEBELİ, 33 dakika önce yazdı:

Merhaba,

RS232 Seri Bağlantı Portu X3 kullanmanız ve aşağıda yer bağlantıyı yapmanız halinde bağlantı kurabilmeniz gerekli. Bağlantı ve kablolamayı nasıl yaptığınız ve RS232 USB dönüştürücü olarak hangi ürünü tercih ettiğiniz hakkında da bilgi paylaşırsanız hatanın nereden ve nasıl kaynaklandığı hakkında daha açıklayıcı olabilir. 

image.png.bbacea6ab6781b8bc5afe506e9bfa7f4.png

İyi günler.

Merhaba Samet Bey,

Cevabınız için teşekkür ederim. Prolific PL2303 XA/HXA chip kullanıyorum yukarıdaki bağlantıyı yaptım zaten bağlanıyor bağlantı açık kalıyor chip için gerekli bağlantı ayaklarına da baktım öyle lehimledim. Sürücü hatası olabilir mi diye kontrol ettim kendi kontrol yazılımı sorunsuz iletişim kurabiliyor. Baudrateleri de kontrol ettim hem yazılım bağlantısındaki hem servo üzerindeki hem de sürücü ayarlarındaki baudrate değerleri de aynı

Link to comment
Share on other sites

Merhaba,

Sürücüden kaynaklı bir hata olma ihtimali yeni aldığınız bir cihaz da herhangi bir kullanıcı hatası nedeniyle yaşanmış bir sorun kaynaklı olmadıktan sonra hiç karşılaşmadım diyebilirim.

Öncelikle kullandığınız PC de, Servo programının çalışmasını engelleyebilecek herhangi kısıtlayıcı program olmadığına sonrasında ise başka bir RS232 - USB çevirici ile testinizi yapmanızı rica edeceğim. RS232-USB çeviricinizin çalıştığını belirttiğiniz kontrol yazılımınızda da servo yazılımında kullandığınız ayarlar ile mi test yapıyorsunuz. Sektörde bazı çeviriciler, çalışma hızları (Baudrate ) ve veri alış-verişi sırasında kullandıkları tampon bellekleri yetersiz olabiliyor. Bu nedenle test programınız da hata almayıp, Servo yazılımında gerçekleşen yüksek hızda haberleşme ve veri alış-verişine yanıt veremiyor olabilir. Sizlerden ricam öncelikle bu bilgiler doğrultusunda Servo Sürünüzü fabrika ayarlarına döndürerek ve kullandığınız çeviriciyi değiştirerek deneme yapmanız olucak, ayrıca bağlantıyı nasıl yaptığınızı da sormuştum, kablolamayı nasıl yaptığınızı da belirtebilir misiniz.

İyi günler.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...